[node.js] エラー[SECURITY] open has 1 critical vulnerability. が出たとき

カテゴリ: Node.js

node.jsを使っていると、npmで下記のエラーが出力されることがあります。

npm WARN notice [SECURITY] open has 1 critical vulnerability. 
Go here for more details: https://nodesecurity.io/advisories?search=open&version=0.0.5
- Run `npm i npm@latest -g` to upgrade your npm version, 
and then `npm audit` to get more info.

これは、使用している環境にセキュリティホールが検出ものを使用しているためです。

問題を解消するには、メッセージにあるようにIInpm i npm@latest -gコマンドを実行します。環境によってはsudoをつけて管理者権限で実行する必要があります。

$ sudo npm i npm@latest -g

/usr/bin/npm -> /usr/lib/node_modules/npm/bin/npm-cli.js
/usr/bin/npx -> /usr/lib/node_modules/npm/bin/npx-cli.js
+ npm@6.0.1
added 246 packages, removed 40 packages and updated 125 packages in 11.289s

Amazonでおトクに買い物する方法
AmazonチャージでポイントGET


Amazonは買いもの前にAmazonギフト券をチャージしてポイントをゲットしないと損!

こちらもおススメ

コメントを残す

メールアドレスが公開されることはありません。