[python]エラー:You are using pip version 9.0.3, however version x.x.x is available.

カテゴリ: 未分類

pythonのパッケージマネージャである、pipを使用すると下記の警告が表示されることがあります

$ pip install scikit-learn
...

You are using pip version 9.0.3, however version 10.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

これは、使用しているpipのバージョンが古いために表示される警告です。警告を出なくするには、メッセージに記載されている通りpip install --upgrade pipコマンドを実行すれば良いです。

$pip install --upgrade pip

Collecting pip
  Downloading https://files.pythonhosted.org/packages/0f/74/ecd13431bcc456ed390b44c8a6e917c1820365cbebcb6a8974d1cd045ab4/pip-10.0.1-py2.py3-none-any.whl (1.3MB)
    100% |████████████████████████████████| 1.3MB 790kB/s
Installing collected packages: pip
  Found existing installation: pip 9.0.3
    Uninstalling pip-9.0.3:
      Successfully uninstalled pip-9.0.3
Successfully installed pip-10.0.1
こちらもおススメ

コメントを残す

メールアドレスが公開されることはありません。